cancel
Showing results for 
Search instead for 
Did you mean: 

So, a new field was added and now the iPads do not sync. Is this a view issue?

Highlighted
Sushi Chef
Sushi Chef

So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

If so, is there an easy way to check which views are affected?

1 Solution

Accepted Solutions
Employee
Employee

Re: So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

Hi Alan,

If a new field was added to the WO object as REQUIRED in the object/field settings then it must have a value to save or edit the WO record (see screen shot below) otherwise it will give you a sync error your seeing now.  Check the Required flag on the field because it is completely independent of the REQUIRED flag on the page layout. If that's the issue then you can fix your problem immediately by removing the REQUIRED flag on the field level (see screen shot below) and performing a SYNC DATA.   You can make fields REQUIRED on the page layout and that will not break the Mobile sync.

aidankirkpatrick‌ mobile‌ sync‌ requiredfields‌ ipad‌

View solution in original post

Employee
Employee

Re: So, a new field was added and now the iPads do not sync.  Is this a view issue?

Jump to solution

Was a configure sync done by all end users post the field being added? What field was added and on what object? What is the field level permission on this field?

Sushi Chef
Sushi Chef

Re: So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

So, I believe a Config Sync was done, but will have to confirm this.  The field is called "P/O Date & Time".  It is a Date/Time data type, and is in the SVMX Work Order object.  It is a required field.  I don't know how to check what field level permissions it has!

Employee
Employee

Re: So, a new field was added and now the iPads do not sync.  Is this a view issue?

Jump to solution

If required was the field added to the SFM page layout? How are the iPads not syncing? Is there an error? You check field level security by going to the field under Salesforce SetUp ( here is an article from Salesforce H&T-  Field-Level Security Overview )

Sushi Chef
Sushi Chef

Re: So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

Thanks George for helping on this.  So, the field is not in any SFM page layouts.  I have changed it to be not required, and it seems that it is visible to all users, and is not read only.  Does this shed any light on the issue?

Employee
Employee

Re: So, a new field was added and now the iPads do not sync.  Is this a view issue?

Jump to solution

If you have just done this then a config sync will be needed post this change so that the mobile device is in sync with the server.

Employee
Employee

Re: So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

Hi Alan,

If a new field was added to the WO object as REQUIRED in the object/field settings then it must have a value to save or edit the WO record (see screen shot below) otherwise it will give you a sync error your seeing now.  Check the Required flag on the field because it is completely independent of the REQUIRED flag on the page layout. If that's the issue then you can fix your problem immediately by removing the REQUIRED flag on the field level (see screen shot below) and performing a SYNC DATA.   You can make fields REQUIRED on the page layout and that will not break the Mobile sync.

aidankirkpatrick‌ mobile‌ sync‌ requiredfields‌ ipad‌

View solution in original post

Sushi Chef
Sushi Chef

Re: So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

Thanks @George Piper and mike.monin your help on this.  The config sync eventually went through on all devices (so far) and then (having removed the required option from the field) the data syncs went through too!

Employee
Employee

Re: So, a new field was added and now the iPads do not sync. Is this a view issue?

Jump to solution

Great to hear and glad to help!